Jul 312023
 

Older versions of BDLib for Minecraft 1.7 – 1.12 contain a known security vulnerability.

You can read more about the vulnerability here – https://blog.mmpa.info/posts/bleeding-pipe

I’m releasing updated builds for 1.7.10 and 1.10.2, a version for 1.12 will be available soon(tm).

Updated: A version for 1.12.2 was added as well.

In general I do not recommend playing those old versions on public open servers, even with those fixed versions – there’s still many other known vulnerable mods from other authors out there.

This does not affect single player.

If you do want to play multiplayer I recommend installing one of those 2 mods, though I can’t guarantee they completely fix the issue – https://github.com/dogboy21/serializationisbad/releases or https://modrinth.com/mod/pipeblocker

BDLib
bdlib-1.12.5.1-mc1.10.2.jar
Version: 1.12.5.1 (For Minecraft: 1.10.2)
1.9 MiB
567 Downloads
Details
BDLib
bdlib-1.9.5.1-mc1.7.10.jar
Version: 1.9.5.1 (For Minecraft: 1.7.10)
1.4 MiB
581 Downloads
Details
BDLib
bdlib-1.14.4.1-mc1.12.2.jar
Version: 1.14.4.1 (For Minecraft: 1.12.2)
2.2 MiB
573 Downloads
Details

 Posted by at 5:02 am

 Leave a Reply

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

(required)

(required)